From b3be3738c766ad9420551594e084db93e5b17b3d Mon Sep 17 00:00:00 2001
From: Joey Hess <joey@kodama.kitenet.net>
Date: Tue, 15 Jan 2008 14:34:55 -0500
Subject: move, don't delete

---
 debian/changelog |  1 -
 debian/postinst  |  7 +++++++
 debian/preinst   | 36 ++++++++++++++++++------------------
 3 files changed, 25 insertions(+), 19 deletions(-)

(limited to 'debian')

diff --git a/debian/changelog b/debian/changelog
index 0769d9a..7e45fb2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,7 +8,6 @@ etckeeper (0.10) UNRELEASED; urgency=low
   * Split out an unclean.d that tests if the WC contains uncommitted
     changes.
   * Don't commit in post-install.d if there are no uncommitted changes.
-  * Add preinst code to remove old post-install.d scripts.
   * German debconf translation. Closes: #460940, #458751
   * Use git status instead of git-status (missed this one before).
 
diff --git a/debian/postinst b/debian/postinst
index ef872b3..7cd4573 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -52,4 +52,11 @@ configure)
 		mv_conffile "/etc/etckeeper/init.d/70git-add" \
 			"/etc/etckeeper/init.d/70git-add"
 	fi
+	if dpkg --compare-versions "$2" le "0.10"; then
+        	for c in 10vcs-test 30git-add 30hg-addremove 40git-rm; do
+			mv_conffile "/etc/etckeeper/post-install.d/$c" \
+				"/etc/etckeeper/commit.d/$c"
+
+		done
+	fi
 esac
diff --git a/debian/preinst b/debian/preinst
index 7caa62d..3b927e4 100644
--- a/debian/preinst
+++ b/debian/preinst
@@ -18,23 +18,23 @@ prep_mv_conffile() {
 }
 
 # Remove a no-longer used conffile
-rm_conffile() {
-	PKGNAME="$1"
-	CONFFILE="$2"
-
-	if [ -e "$CONFFILE" ]; then
-		md5sum="`md5sum \"$CONFFILE\" | sed -e \"s/ .*//\"`"
-		old_md5sum="`dpkg-query -W -f='${Conffiles}' $PKGNAME | sed -n -e \"\\\\' $CONFFILE'{s/ obsolete$//;s/.* //p}\"`"
-		if [ "$md5sum" != "$old_md5sum" ]; then
-			echo "Obsolete conffile $CONFFILE has been modified by you."
-			echo "Saving as $CONFFILE.dpkg-bak ..."
-			mv -f "$CONFFILE" "$CONFFILE".dpkg-bak
-		else
-			echo "Removing obsolete conffile $CONFFILE ..."
-			rm -f "$CONFFILE"
-		fi
-	fi
-}
+#rm_conffile() {
+#	PKGNAME="$1"
+#	CONFFILE="$2"
+#
+#	if [ -e "$CONFFILE" ]; then
+#		md5sum="`md5sum \"$CONFFILE\" | sed -e \"s/ .*//\"`"
+#		old_md5sum="`dpkg-query -W -f='${Conffiles}' $PKGNAME | sed -n -e \"\\\\' $CONFFILE'{s/ obsolete$//;s/.* //p}\"`"
+#		if [ "$md5sum" != "$old_md5sum" ]; then
+#			echo "Obsolete conffile $CONFFILE has been modified by you."
+#			echo "Saving as $CONFFILE.dpkg-bak ..."
+#			mv -f "$CONFFILE" "$CONFFILE".dpkg-bak
+#		else
+#			echo "Removing obsolete conffile $CONFFILE ..."
+#			rm -f "$CONFFILE"
+#		fi
+#	fi
+#}
 
 case "$1" in
 install|upgrade)
@@ -52,7 +52,7 @@ install|upgrade)
 	fi
 	if dpkg --compare-versions "$2" le "0.10"; then
         	for c in 10vcs-test 30git-add 30hg-addremove 40git-rm; do
-			rm_conffile etckeeper "/etc/etckeeper/post-install.d/$c"
+			prep_mv_conffile etckeeper "/etc/etckeeper/post-install.d/$c"
 
 		done
 	fi
-- 
cgit v1.2.3