summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/cron.daily7
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 77c3b4a..aeaea9d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,9 @@ etckeeper (1.18.4) UNRELEASED; urgency=medium
Thanks, Tilman Blumenbach and Christian Hesse.
* Only run Pacman hooks when files in /etc have changed.
Thanks, Christian Hesse.
+ * Added systemd timer that can run etckeeper 10 minutes after boot, and also
+ daily. It's not enabled by default, partly because of overlap with the
+ cron job.
-- Joey Hess <id@joeyh.name> Mon, 29 Feb 2016 11:12:08 -0400
diff --git a/debian/cron.daily b/debian/cron.daily
index e00e570..eb74401 100644
--- a/debian/cron.daily
+++ b/debian/cron.daily
@@ -1,5 +1,8 @@
#!/bin/sh
set -e
-if [ -e /etc/etckeeper/daily ]; then
- /etc/etckeeper/daily
+if [ -e /etc/etckeeper/daily ] && [ -e /etc/etckeeper/etckeeper.conf ]; then
+ . /etc/etckeeper/etckeeper.conf
+ if [ "$AVOID_DAILY_AUTOCOMMITS" != "1" ]; then
+ /etc/etckeeper/daily
+ fi
fi