summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/preinst5
2 files changed, 7 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 12b2dc6..9578431 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ etckeeper (0.50) UNRELEASED; urgency=low
* Add Danish translation of debconf templates. Closes: #597768
* Ignore /etc/.initctl. Closes: #598121
+ * Do not warn about special files or hardlinks if they are ignored by
+ git. Fixes #549354 for git, but not for other VCSs.
-- Joey Hess <joeyh@debian.org> Wed, 22 Sep 2010 17:45:57 -0400
diff --git a/debian/preinst b/debian/preinst
index 11647a1..d7011d9 100644
--- a/debian/preinst
+++ b/debian/preinst
@@ -69,6 +69,11 @@ install|upgrade)
rm_conffile etckeeper "/etc/etckeeper/commit.d/$c"
done
fi
+ if dpkg --compare-versions "$2" le "0.50"; then
+ for c in 20warn-hardlinks 20warn-special-file; do
+ rm_conffile etckeeper "/etc/etckeeper/pre-commit.d/$c"
+ done
+ fi
# delete files the prerm stashes away to handle purging
rm -rf /var/cache/etckeeper/stash