summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/cron.daily15
2 files changed, 9 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index 5ffa2f6..ce34061 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,7 +3,13 @@ etckeeper (1.18.4) UNRELEASED; urgency=medium
* Optimised find for special and hard linked files.
Thanks, Rike-Benjamin Schuppner.
* Adjust when Pacman 5 calls etckeeper hooks.
- Thanks, Tilman Blumenbach.
+ Thanks, Tilman Blumenbach and Christian Hesse.
+ * Only run Pacman hooks when files in /etc have changed.
+ Thanks, Christian Hesse.
+ * Added systemd timer that can run etckeeper 10 minutes after boot, and also
+ daily. It's not enabled by default, partly because of overlap with the
+ cron job.
+ Thanks, Christian Hesse.
-- Joey Hess <id@joeyh.name> Mon, 29 Feb 2016 11:12:08 -0400
diff --git a/debian/cron.daily b/debian/cron.daily
index 5255691..eb74401 100644
--- a/debian/cron.daily
+++ b/debian/cron.daily
@@ -1,19 +1,8 @@
#!/bin/sh
set -e
-if [ -x /usr/bin/etckeeper ] && [ -e /etc/etckeeper/etckeeper.conf ]; then
+if [ -e /etc/etckeeper/daily ] && [ -e /etc/etckeeper/etckeeper.conf ]; then
. /etc/etckeeper/etckeeper.conf
if [ "$AVOID_DAILY_AUTOCOMMITS" != "1" ]; then
- # avoid autocommit if an install run is in progress
- lockfile=/var/cache/etckeeper/packagelist.pre-install
- if [ -e "$lockfile" ] && [ -n "$(find "$lockfile" -mtime +1)" ]; then
- rm -f "$lockfile" # stale
- fi
- if [ ! -e "$lockfile" ]; then
- AVOID_SPECIAL_FILE_WARNING=1
- export AVOID_SPECIAL_FILE_WARNING
- if etckeeper unclean; then
- etckeeper commit "daily autocommit" >/dev/null
- fi
- fi
+ /etc/etckeeper/daily
fi
fi