summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/control24
-rw-r--r--debian/copyright6
-rwxr-xr-xdebian/rules11
4 files changed, 27 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index 51dc153..0925dbf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,5 @@
- (0.1) unstable; urgency=low
+etckeeper (0.1) unstable; urgency=low
* First release.
- -- Joey Hess <joeyh@debian.org>
+ -- Joey Hess <joeyh@debian.org> Mon, 05 Nov 2007 16:43:04 -0500
diff --git a/debian/control b/debian/control
index 81b5c35..01735ab 100644
--- a/debian/control
+++ b/debian/control
@@ -1,14 +1,20 @@
-Source:
-Section: utils
+Source: etckeeper
+Section: admin
Priority: optional
-Build-Depends: debhelper (>= 5)
+Build-Depends: debhelper (>= 5), dpkg-dev (>= 1.9.0)
Maintainer: Joey Hess <joeyh@debian.org>
Standards-Version: 3.7.2
-Homepage:
-Vcs-Git:
+Vcs-Git: git://git.kitenet.net/etckeeper
-Package:
+Package: etckeeper
Architecture: all
-Section:
-Depends:
-Description:
+Section: admin
+Depends: metastore, git-core, ${misc:Depends}
+Description: store /etc in git
+ etckeeper is a collection of tools to let /etc be stored in a git
+ repository. It hooks into apt to automatically commit changes made to /etc
+ during package upgrades. It uses `metastore` to track file metadata that
+ git does not normally support, but that is important for /etc, such as the
+ permissions of `/etc/shadow`. It's quite modular and configurable, while
+ also being simple to use if you understand the basics of working with git.
+
diff --git a/debian/copyright b/debian/copyright
index 24c49f0..9ff61e0 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,5 +1,5 @@
Files: *
-Copyright: (c) 2007 Joey Hess <joeyh@debian.org>
+Copyright: © 2007 Joey Hess <joey@kitenet.net>
License: GPL-2+
- On Debian systems, the complete text of the GPL can be found in
- /usr/share/common-licenses/GPL.
+ The full text of the GPL is distributed as doc/GPL in etckeeper's source,
+ and is distributed in /usr/share/common-licenses/GPL-2 on Debian systems.
diff --git a/debian/rules b/debian/rules
index cc95420..a759dac 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,7 @@
#!/usr/bin/make -f
build:
+ dh_testdir
clean:
dh_testdir
@@ -13,18 +14,20 @@ binary-indep: build
dh_testdir
dh_testroot
dh_clean -k
- dh_install
- dh_installdocs
+ $(MAKE) PREFIX=debian/etckeeper
+ dh_installdocs README
dh_installexamples
- dh_installman
dh_installchangelogs
dh_compress
dh_fixperms
- dh_perl
dh_installdeb
dh_gencontrol
dh_md5sums
dh_builddeb
+# Not intended for use by anyone except the author.
+announcedir:
+ @echo ${HOME}/src/joeywiki/code/etckeeper/news
+
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary