diff options
author | emkael <emkael@tlen.pl> | 2017-02-22 21:34:47 +0100 |
---|---|---|
committer | emkael <emkael@tlen.pl> | 2017-02-22 21:34:47 +0100 |
commit | 966fe772cc0c8ac2e0315910ea1e277cd5d6029a (patch) | |
tree | fdc8782b5f37081a125b4584f3af3342171d9144 | |
parent | 4d7be8c8fb1d12bb87b5a29c8ad8ff9515080334 (diff) |
EXE compilation metadata
-rw-r--r-- | .gitignore | 2 | ||||
-rw-r--r-- | .version | 42 | ||||
-rw-r--r-- | icon.xcf | bin | 0 -> 16183 bytes | |||
-rw-r--r-- | playoff.ico | bin | 0 -> 1167 bytes | |||
-rw-r--r-- | playoff.spec | 18 |
5 files changed, 62 insertions, 0 deletions
@@ -1,2 +1,4 @@ *.pyc *.json +build/* +dist/* diff --git a/.version b/.version new file mode 100644 index 0000000..3670688 --- /dev/null +++ b/.version @@ -0,0 +1,42 @@ +# UTF-8 +VSVersionInfo( + ffi=FixedFileInfo( + filevers=(1, 0, 0, 0), + prodvers=(1, 0, 0, 0), + # Contains a bitmask that specifies the valid bits 'flags' + mask=0x3f, + # Contains a bitmask that specifies the Boolean attributes of the file. + flags=0x0, + # The operating system for which this file was designed. + # 0x4 - NT and there is no need to change it. + OS=0x4, + # The general type of file. + # 0x1 - the file is an application. + fileType=0x1, + # The function of the file. + # 0x0 - the function is not defined for this fileType + subtype=0x0, + # Creation date and time stamp. + date=(0, 0) + ), + kids=[ + StringFileInfo( + [ + StringTable( + u'040904b0', # 0x0409(1033)= English, 0x04b0(1200)= UTF-8 + [StringStruct(u'CompanyName', u'emkael.info'), + StringStruct(u'ProductName', u'teamy_playoff'), + StringStruct(u'ProductVersion', u'1, 0, 0, 0'), + StringStruct(u'InternalName', u'teamy_playoff'), + StringStruct(u'OriginalFilename', u'playoff.exe'), + StringStruct(u'FileVersion', u'1, 0, 0, 0'), + StringStruct( + u'FileDescription', + u'Play-off visualisation for JFR Teamy events'), + StringStruct(u'LegalCopyright', + u'© 2017 mkl (Michał Klichowicz)'), + StringStruct(u'LegalTrademarks', u'')]) + ]), + VarFileInfo([VarStruct(u'Translation', [1033, 1200])]) + ] +) diff --git a/icon.xcf b/icon.xcf Binary files differnew file mode 100644 index 0000000..adb4cc4 --- /dev/null +++ b/icon.xcf diff --git a/playoff.ico b/playoff.ico Binary files differnew file mode 100644 index 0000000..0cdb123 --- /dev/null +++ b/playoff.ico diff --git a/playoff.spec b/playoff.spec new file mode 100644 index 0000000..7246d59 --- /dev/null +++ b/playoff.spec @@ -0,0 +1,18 @@ +import os +a = Analysis(['playoff.py'], + pathex=[os.path.abspath('.')], + hiddenimports=[], + hookspath=None, + runtime_hooks=None, + excludes=None) +pyz = PYZ(a.pure) +exe = EXE(pyz, + a.scripts, + a.binaries, + a.zipfiles, + a.datas, + name='playoff.exe', + debug=False, + strip=None, + upx=True, + console=True, version=".version", icon="playoff.ico" ) |