summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2007-11-05 16:48:06 -0500
committerJoey Hess <joey@kodama.kitenet.net>2007-11-05 16:48:06 -0500
commit4a808ca40fc19e2acbe72205f0087dbf9c48e31b (patch)
tree84274a61b99b58917965f9f572b902072ea88749 /debian/rules
parente078efb6617b74873953cafa1e76414cd0993da8 (diff)
debianisation
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules33
1 files changed, 33 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a759dac
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+build:
+ dh_testdir
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+binary-arch: build
+
+binary-indep: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ $(MAKE) PREFIX=debian/etckeeper
+ dh_installdocs README
+ dh_installexamples
+ dh_installchangelogs
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+# Not intended for use by anyone except the author.
+announcedir:
+ @echo ${HOME}/src/joeywiki/code/etckeeper/news
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary