summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJoey Hess <joey@kodama.kitenet.net>2008-04-26 19:27:29 -0400
committerJoey Hess <joey@kodama.kitenet.net>2008-04-26 19:27:29 -0400
commite62dfd56e2a0b65c4a272c7caa88189ce2c38b4d (patch)
treeff63017a03a20c7d75f540df95a34776b8c59e9d /debian/rules
parent1c68da7a92bddf1485047c6c632bc5263192dca3 (diff)
debhelper v7; rules file minimisation
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules32
1 files changed, 2 insertions, 30 deletions
diff --git a/debian/rules b/debian/rules
index 28e3c1b..4fe53ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,35 +1,7 @@
#!/usr/bin/make -f
-
-build:
- dh_testdir
-
-clean:
- dh_testdir
- dh_testroot
- dh_clean
-
-binary-arch: build
-
-binary-indep: build
- dh_testdir
- dh_testroot
- dh_clean -k
- $(MAKE) install DESTDIR=debian/etckeeper
- dh_pysupport
- dh_installdocs README TODO
- dh_installexamples
- dh_installchangelogs
- dh_compress
- dh_fixperms
- dh_installdebconf
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+%:
+ dh $@
# Not intended for use by anyone except the author.
announcedir:
@echo ${HOME}/src/joeywiki/code/etckeeper/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary