summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-01-14 12:42:46 -0400
committerJoey Hess <joey@kitenet.net>2012-01-14 12:42:46 -0400
commit144c438e8e74113dd4c29e38a45eb6481a3271d3 (patch)
tree4661daecaa94d3fbf5ad6ea696f9c52f4644f534 /debian
parent8560b99a4ae5b5749791609c341a7a0f22331f8a (diff)
Fix up botched git-rm conffile removal from 0.58.
The file could be in any of three states; absent, present, or .dpkg-dist. Finish fully removing it. Closes: #655836
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/postinst4
-rw-r--r--debian/preinst2
3 files changed, 13 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 61c3556..65b07c0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+etckeeper (0.61) UNRELEASED; urgency=low
+
+ * Fix up botched git-rm conffile removal from 0.58.
+ The file could be in any of three states; absent, present, or .dpkg-dist.
+ Finish fully removing it. Closes: #655836
+
+ -- Joey Hess <joeyh@debian.org> Sat, 14 Jan 2012 12:30:07 -0400
+
etckeeper (0.60) unstable; urgency=low
* Updated Dutch translation of debconf templates. Closes: #654244
diff --git a/debian/postinst b/debian/postinst
index 496a5d8..59e9f4a 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -72,6 +72,10 @@ configure)
fi
done
fi
+ if dpkg --compare-versions "$2" le "0.61"; then
+ # may be left over from a botched conffile removal
+ rm -f /etc/etckeeper/commit.d/40git-rm.dpkg-dist
+ fi
if [ "$2" = "" ] && [ -e "/etc/etckeeper/etckeeper.conf" ]; then
# Fresh install.
diff --git a/debian/preinst b/debian/preinst
index 029ae31..4dda427 100644
--- a/debian/preinst
+++ b/debian/preinst
@@ -74,7 +74,7 @@ install|upgrade)
rm_conffile etckeeper "/etc/etckeeper/pre-commit.d/$c"
done
fi
- if dpkg --compare-versions "$2" le "0.58"; then
+ if dpkg --compare-versions "$2" le "0.61"; then
rm_conffile etckeeper "/etc/etckeeper/commit.d/40git-rm"
fi