summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2013-07-26 11:03:45 -0400
committerJoey Hess <joey@kitenet.net>2013-07-26 11:03:45 -0400
commite3875983addfb7f02a3434ddf4c7c6bbde6dd2f8 (patch)
treefbf403ad9c2c8763ef321cacfbf595ec9fe5e7e3 /debian
parenta890ac4a2ca4c9580b4a2e3a0c84f0ba249867dc (diff)
cron.daily: Fix typo in stale lockfile handling code. Closes: #717908
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/cron.daily2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 3dfc62f..dc033fb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,8 @@ etckeeper (1.5) UNRELEASED; urgency=low
* Use user.name and user.email from the .gitconfig file belonging to the
user who sued or sudoed to root, in preference to making up values for
that user.
+ * cron.daily: Fix typo in stale lockfile handling code.
+ Closes: #717908
-- Joey Hess <joeyh@debian.org> Wed, 26 Jun 2013 13:15:03 -0400
diff --git a/debian/cron.daily b/debian/cron.daily
index ae41795..5255691 100644
--- a/debian/cron.daily
+++ b/debian/cron.daily
@@ -5,7 +5,7 @@ if [ -x /usr/bin/etckeeper ] && [ -e /etc/etckeeper/etckeeper.conf ]; then
if [ "$AVOID_DAILY_AUTOCOMMITS" != "1" ]; then
# avoid autocommit if an install run is in progress
lockfile=/var/cache/etckeeper/packagelist.pre-install
- if [ -e "$pe" ] && [ -n "$(find "$lockfile" -mtime +1)" ]; then
+ if [ -e "$lockfile" ] && [ -n "$(find "$lockfile" -mtime +1)" ]; then
rm -f "$lockfile" # stale
fi
if [ ! -e "$lockfile" ]; then