summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/postinst7
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index bf2bb75..90e4ab9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ etckeeper (0.29) unstable; urgency=low
The cron job is enabled by default but can be disabled
via etckeeper.conf.
(Thanks to Thierry Carrez)
+ * Fix executable bits on two darcs support scripts.
-- Joey Hess <joeyh@debian.org> Fri, 13 Feb 2009 13:43:02 -0500
diff --git a/debian/postinst b/debian/postinst
index e4fb0b3..039c4c0 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -65,4 +65,11 @@ configure)
mv_conffile "/etc/etckeeper/init.d/20restore-metadata" \
"/etc/etckeeper/init.d/10restore-metadata"
fi
+ if dpkg --compare-versions "$2" le "0.28"; then
+ for c in commit.d/30darcs-add init.d/60darcs-deleted-symlinks; do
+ if [ -e /etc/etckeeper/$c ]; then
+ chmod +x /etc/etckeeper/$c
+ fi
+ done
+ fi
esac