summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/postinst6
2 files changed, 16 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 90a7ab1..a6efb76 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,16 @@ etckeeper (0.32) UNRELEASED; urgency=low
* Implement list-installed for rpm.
* Added a spec file contributed by Jimmy Tang.
+ * Add uninit subcommand, which cleans up all etckeeper and VCS droppings
+ in /etc. This is useful if you want to switch to a different VCS and
+ don't have any history to preserve. (Preserving history and converting
+ is of course possible, but significantly harder.)
+ * Run etckeeper init on initial install. Closes: #505772
+ (The idea being that if someone doesn't want to use git, they can
+ immediatly uninit to easily reverse this.)
+ * Document how to change the VCS used by etckeeper, without preserving
+ any history. Preserving history left as an exersise for the reader.
+ Closes: #515237
-- Joey Hess <joeyh@debian.org> Tue, 17 Feb 2009 21:49:29 -0500
diff --git a/debian/postinst b/debian/postinst
index 834b069..870d67b 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -73,6 +73,12 @@ configure)
done
fi
+ if [ "$2" = "" ]; then
+ # Fresh install.
+ # Might fail if, eg, git is not installed.
+ etckeeper init || echo "etckeeper init failed; run it by hand" >&2
+ fi
+
# prints error and exits nonzero if the ignore file cannot be updated
etckeeper update-ignore || true
esac