summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control20
-rw-r--r--debian/copyright5
-rwxr-xr-xdebian/rules33
5 files changed, 64 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..0925dbf
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+etckeeper (0.1) unstable; urgency=low
+
+ * First release.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 05 Nov 2007 16:43:04 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..01735ab
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,20 @@
+Source: etckeeper
+Section: admin
+Priority: optional
+Build-Depends: debhelper (>= 5), dpkg-dev (>= 1.9.0)
+Maintainer: Joey Hess <joeyh@debian.org>
+Standards-Version: 3.7.2
+Vcs-Git: git://git.kitenet.net/etckeeper
+
+Package: etckeeper
+Architecture: all
+Section: admin
+Depends: metastore, git-core, ${misc:Depends}
+Description: store /etc in git
+ etckeeper is a collection of tools to let /etc be stored in a git
+ repository. It hooks into apt to automatically commit changes made to /etc
+ during package upgrades. It uses `metastore` to track file metadata that
+ git does not normally support, but that is important for /etc, such as the
+ permissions of `/etc/shadow`. It's quite modular and configurable, while
+ also being simple to use if you understand the basics of working with git.
+
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..9ff61e0
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,5 @@
+Files: *
+Copyright: © 2007 Joey Hess <joey@kitenet.net>
+License: GPL-2+
+ The full text of the GPL is distributed as doc/GPL in etckeeper's source,
+ and is distributed in /usr/share/common-licenses/GPL-2 on Debian systems.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a759dac
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+
+build:
+ dh_testdir
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+binary-arch: build
+
+binary-indep: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ $(MAKE) PREFIX=debian/etckeeper
+ dh_installdocs README
+ dh_installexamples
+ dh_installchangelogs
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+# Not intended for use by anyone except the author.
+announcedir:
+ @echo ${HOME}/src/joeywiki/code/etckeeper/news
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary