summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/control1
-rw-r--r--debian/cron.daily8
3 files changed, 18 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7fb57b4..b357968 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+etckeeper (0.29) UNRELEASED; urgency=low
+
+ * Add a daily cron job to autocommit changes to /etc. Closes: #515100
+ The cron job is enabled by default but can be disabled
+ via etckeeper.conf.
+ (Thanks to Thierry Carrez)
+
+ -- Joey Hess <joeyh@debian.org> Fri, 13 Feb 2009 13:30:25 -0500
+
etckeeper (0.28) unstable; urgency=low
* Support darcs. Thanks to Gian Piero Carrubba. Closes: #510032
diff --git a/debian/control b/debian/control
index 5d0b1f1..57d50a7 100644
--- a/debian/control
+++ b/debian/control
@@ -12,6 +12,7 @@ Package: etckeeper
Architecture: all
Section: admin
Depends: git-core (>= 1:1.5.4) | mercurial | bzr (>= 1.4~) | darcs, ${misc:Depends}
+Recommends: cron
Conflicts: bzr (<< 1.4~)
XB-Python-Version: ${python:Versions}
Description: store /etc in git, mercurial, bzr or darcs
diff --git a/debian/cron.daily b/debian/cron.daily
new file mode 100644
index 0000000..ce6cb31
--- /dev/null
+++ b/debian/cron.daily
@@ -0,0 +1,8 @@
+#!/bin/sh
+set -e
+. /etc/etckeeper/etckeeper.conf
+if [ "$AVOID_DAILY_AUTOCOMMITS" != "1" ]; then
+ if /usr/sbin/etckeeper unclean; then
+ /usr/sbin/etckeeper commit "Daily autocommit"
+ fi
+fi