summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rw-r--r--debian/control2
-rw-r--r--debian/preinst5
3 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 44d5466..2dba9a4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,10 @@ etckeeper (0.58) UNRELEASED; urgency=low
a fixup script (attached to the bug) which could be used if you've
already encountered this problem.
* Bugfix for filenames containing single quotes.
+ * Use git add -A, which automatically removes deleted files,
+ and avoids a separate call to git add -u.
+ Thanks to Miklos Vajna, whose patch in 2008 was deferred
+ because -A was then too new, and languished in a branch until found today.
-- Joey Hess <joeyh@debian.org> Fri, 25 Nov 2011 12:00:55 -0400
diff --git a/debian/control b/debian/control
index 71089d9..c578d82 100644
--- a/debian/control
+++ b/debian/control
@@ -11,7 +11,7 @@ Homepage: http://kitenet.net/~joey/code/etckeeper/
Package: etckeeper
Architecture: all
Section: admin
-Depends: git-core (>= 1:1.5.4) | git (>= 1:1.7) | mercurial | bzr (>= 1.5~) | darcs, ${misc:Depends}
+Depends: git (>= 1:1.7) | mercurial | bzr (>= 1.5~) | darcs, ${misc:Depends}
Recommends: cron
Suggests: sudo (>= 1.7.4p4)
Conflicts: bzr (<< 1.5~)
diff --git a/debian/preinst b/debian/preinst
index d7011d9..a510cef 100644
--- a/debian/preinst
+++ b/debian/preinst
@@ -74,6 +74,11 @@ install|upgrade)
rm_conffile etckeeper "/etc/etckeeper/pre-commit.d/$c"
done
fi
+ if dpkg --compare-versions "$2" le "0.58"; then
+ for c in commit.d/40git-rm; do
+ rm_conffile etckeeper "/etc/etckeeper/pre-commit.d/$c"
+ done
+ fi
# delete files the prerm stashes away to handle purging
rm -rf /var/cache/etckeeper/stash